May 11, 2013

Twitter API v1.1 upgrade

  • We've upgraded application to use the Twitter API v1.1 endpoints because the previous version of the API is being retired. This change now requires you to authenticate on Twitter in order to access their service.
  • The new API provides additional information which helps in reducing the number of requests required to collect user data and helps reduce the bandwidth used by the app.
  • There are limits imposed by Twitter on their new API, information about this can be found here. In general, these limits will not impact you but depending on what features you use, you may hit rate limits on certain features.
  • We've also made improvements on how data is processed using a background service to further improve the responsiveness of the app.